Security update for the Linux Kernel (Live Patch 13 for SLE 15 SP2)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 13 for SLE 15 SP2)
Announcement ID: SUSE-SU-2022:1591-1
Rating: important
References: #1195950 #1198133
Cross-References:CVE-2022-0330 CVE-2022-1158
Affected Products:
  • SUSE Linux Enterprise High Performance Computing 15-SP2
  • SUSE Linux Enterprise Module for Live Patching 15-SP2
  • SUSE Linux Enterprise Server 15-SP2
  • SUSE Linux Enterprise Server for SAP Applications 15-SP2

An update that fixes two vulnerabilities is now available.

Description:

This update for the Linux Kernel 5.3.18-24_64 fixes several issues.
The following security issues were fixed:

  • - CVE-2022-1158: Fixed KVM x86/mmu compare-and-exchange of gPTE via the user address (bsc#1198133)
  • CVE-2022-0330: A random memory access flaw was found in the Linux kernel's GPU i915 kernel driver functionality in the way a user may run malicious code on the GPU. This flaw allowed a local user to crash the system or escalate their privileges on the system. (bsc#1195950)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Live Patching 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP2-2022-1591=1

Package List:

  • SUSE Linux Enterprise Module for Live Patching 15-SP2 (ppc64le s390x x86_64):
    • kernel-livepatch-5_3_18-24_64-default-16-150200.2.1
    • kernel-livepatch-5_3_18-24_64-default-debuginfo-16-150200.2.1
    • kernel-livepatch-SLE15-SP2_Update_13-debugsource-16-150200.2.1

References: