Security update for htmldoc

SUSE Security Update: Security update for htmldoc
Announcement ID: SUSE-SU-2022:14877-1
Rating: important
References: #1194487
Cross-References:CVE-2021-43579
Affected Products:
  • Subscription Management Tool for SUSE Linux Enterprise 11-SP3

An update that fixes one vulnerability is now available.

Description:

This update for htmldoc fixes the following issues:

  • CVE-2021-43579: Fixed stack-based buffer overflow in image_load_bmp() resulting in remote code execution if the victim converts an HTML document linking to a crafted BMP file. (bsc#1194487)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • Subscription Management Tool for SUSE Linux Enterprise 11-SP3:
    zypper in -t patch slesmtsp3-htmldoc-14877=1

Package List:

  • Subscription Management Tool for SUSE Linux Enterprise 11-SP3 (i586 s390x x86_64):
    • htmldoc-1.8.27-170.4.6.1

References: