Security update for openssl-1_0_0

SUSE Security Update: Security update for openssl-1_0_0
Announcement ID: SUSE-SU-2022:0856-1
Rating: important
References: #1196877
Cross-References:CVE-2022-0778
Affected Products:
  • SUSE CaaS Platform 4.0
  • SUSE Enterprise Storage 6
  • SUSE Enterprise Storage 7
  • SUSE Linux Enterprise High Performance Computing
  • SUSE Linux Enterprise Module for Legacy Software 15-SP3
  • SUSE Linux Enterprise Module for Legacy Software 15-SP4
  • SUSE Linux Enterprise Server
  • SUSE Linux Enterprise Server 15-LTSS
  • SUSE Linux Enterprise Server 15-SP1-BCL
  • SUSE Linux Enterprise Server 15-SP1-LTSS
  • SUSE Linux Enterprise Server 15-SP2-LTSS
  • SUSE Linux Enterprise Server for SAP 15
  • SUSE Linux Enterprise Server for SAP 15-SP1
  • SUSE Linux Enterprise Server for SAP 15-SP2
  • SUSE Linux Enterprise Server for SAP Applications
  • SUSE Manager Proxy 4.1
  • SUSE Manager Proxy 4.2
  • SUSE Manager Retail Branch Server 4.1
  • SUSE Manager Server 4.1
  • SUSE Manager Server 4.2

An update that fixes one vulnerability is now available.

Description:

This update for openssl-1_0_0 fixes the following issues:

  • CVE-2022-0778: Infinite loop in BN_mod_sqrt() reachable when parsing certificates (bsc#1196877).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Manager Server 4.1:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.1-2022-856=1
  • SUSE Manager Retail Branch Server 4.1:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.1-2022-856=1
  • SUSE Manager Proxy 4.1:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.1-2022-856=1
  • SUSE Linux Enterprise Server for SAP 15-SP2:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP2-2022-856=1
  • SUSE Linux Enterprise Server for SAP 15-SP1:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2022-856=1
  • SUSE Linux Enterprise Server for SAP 15:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2022-856=1
  • SUSE Linux Enterprise Server 15-SP2-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP2-LTSS-2022-856=1
  • SUSE Linux Enterprise Server 15-SP1-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2022-856=1
  • SUSE Linux Enterprise Server 15-SP1-BCL:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2022-856=1
  • SUSE Linux Enterprise Server 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-2022-856=1
  • SUSE Linux Enterprise Module for Legacy Software 15-SP4:
    zypper in -t patch SUSE-SLE-Module-Legacy-15-SP4-2022-856=1
  • SUSE Linux Enterprise Module for Legacy Software 15-SP3:
    zypper in -t patch SUSE-SLE-Module-Legacy-15-SP3-2022-856=1
  • SUSE Enterprise Storage 7:
    zypper in -t patch SUSE-Storage-7-2022-856=1
  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2022-856=1
  • SUSE CaaS Platform 4.0:
    To install this update, use the SUSE CaaS Platform 'skuba' tool. I will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE Manager Server 4.1 (ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Manager Retail Branch Server 4.1 (x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Manager Proxy 4.1 (x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server for SAP 15-SP2 (ppc64le x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server 15-SP2-LTSS (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Module for Legacy Software 15-SP4 (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl10-1.0.2p-3.49.1
    • libopenssl10-debuginfo-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Linux Enterprise Module for Legacy Software 15-SP3 (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl10-1.0.2p-3.49.1
    • libopenssl10-debuginfo-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Enterprise Storage 7 (aarch64 x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE Enterprise Storage 6 (aarch64 x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1
  • SUSE CaaS Platform 4.0 (x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.49.1
    • libopenssl1_0_0-1.0.2p-3.49.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-1.0.2p-3.49.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.49.1
    • openssl-1_0_0-debugsource-1.0.2p-3.49.1

References: