Security update for the Linux Kernel (Live Patch 22 for SLE 12 SP5)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 22 for SLE 12 SP5)
Announcement ID: SUSE-SU-2021:3361-1
Rating: important
References: #1187054 #1188613
Cross-References:CVE-2021-3573 CVE-2021-3640
Affected Products:
  • SUSE Linux Enterprise Module for Live Patching 15-SP3
  • SUSE Linux Enterprise Module for Live Patching 15-SP2
  • SUSE Linux Enterprise Live Patching 12-SP5

An update that fixes two vulnerabilities is now available.

Description:

This update for the Linux Kernel 4.12.14-122_83 fixes several issues.
The following security issues were fixed:

  • CVE-2021-3640: Fixed a user-after-free bug in the function sco_sock_sendmsg which could lead to local privilege escalation. (bsc#1188613)
  • CVE-2021-3573: Fixed a user-after-free bug in the function hci_sock_bound_ioctl which could lead to local privilege escalation. (bsc#1187054).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Live Patching 15-SP3:
    zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP3-2021-3355=1
  • SUSE Linux Enterprise Module for Live Patching 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP2-2021-3361=1
  • SUSE Linux Enterprise Live Patching 12-SP5:
    zypper in -t patch SUSE-SLE-Live-Patching-12-SP5-2021-3373=1

Package List:

  • SUSE Linux Enterprise Module for Live Patching 15-SP3 (ppc64le s390x x86_64):
    • kernel-livepatch-5_3_18-59_19-default-3-2.1
    • kernel-livepatch-5_3_18-59_19-default-debuginfo-3-2.1
    • kernel-livepatch-SLE15-SP3_Update_5-debugsource-3-2.1
  • SUSE Linux Enterprise Module for Live Patching 15-SP2 (ppc64le s390x x86_64):
    • kernel-livepatch-5_3_18-24_78-default-3-2.1
    • kernel-livepatch-5_3_18-24_78-default-debuginfo-3-2.1
    • kernel-livepatch-SLE15-SP2_Update_18-debugsource-3-2.1
  • SUSE Linux Enterprise Live Patching 12-SP5 (ppc64le s390x x86_64):
    • kgraft-patch-4_12_14-122_83-default-3-2.1

References: