Security update for umoci

SUSE Security Update: Security update for umoci
Announcement ID: SUSE-SU-2021:1116-1
Rating: important
References: #1184147
Cross-References:CVE-2021-29136
Affected Products:
  • SUSE Manager Server 4.0
  • SUSE Manager Retail Branch Server 4.0
  • SUSE Manager Proxy 4.0
  • SUSE Linux Enterprise Server for SAP 15-SP1
  • SUSE Linux Enterprise Server 15-SP1-LTSS
  • SUSE Linux Enterprise Server 15-SP1-BCL
  • SUSE Linux Enterprise Module for Containers 15-SP3
  • SUSE Linux Enterprise Module for Containers 15-SP2
  • SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS
  • SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
  • SUSE Enterprise Storage 6
  • SUSE CaaS Platform 4.0

An update that fixes one vulnerability is now available.

Description:

This update for umoci fixes the following issues:

  • Update to umoci v0.4.6.
  • CVE-2021-29136: malicious layer allows overwriting of host files (bsc#1184147)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Manager Server 4.0:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1116=1
  • SUSE Manager Retail Branch Server 4.0:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1116=1
  • SUSE Manager Proxy 4.0:
    zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1116=1
  • SUSE Linux Enterprise Server for SAP 15-SP1:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1116=1
  • SUSE Linux Enterprise Server 15-SP1-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1116=1
  • SUSE Linux Enterprise Server 15-SP1-BCL:
    zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1116=1
  • SUSE Linux Enterprise Module for Containers 15-SP3:
    zypper in -t patch SUSE-SLE-Module-Containers-15-SP3-2021-1116=1
  • SUSE Linux Enterprise Module for Containers 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Containers-15-SP2-2021-1116=1
  • SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1116=1
  • SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1116=1
  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2021-1116=1
  • SUSE CaaS Platform 4.0:
    To install this update, use the SUSE CaaS Platform 'skuba' tool. I will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE Manager Server 4.0 (ppc64le s390x x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Manager Retail Branch Server 4.0 (x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Manager Proxy 4.0 (x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise Module for Containers 15-SP3 (aarch64 ppc64le s390x x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise Module for Containers 15-SP2 (aarch64 ppc64le s390x x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64 x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64 x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE Enterprise Storage 6 (aarch64 x86_64):
    • umoci-0.4.6-3.9.1
  • SUSE CaaS Platform 4.0 (x86_64):
    • umoci-0.4.6-3.9.1

References: