Security update for openexr

SUSE Security Update: Security update for openexr
Announcement ID: SUSE-SU-2021:1097-1
Rating: moderate
References: #1184172 #1184173 #1184174
Cross-References:CVE-2021-3474 CVE-2021-3475 CVE-2021-3476
Affected Products:
  • SUSE Linux Enterprise Module for Desktop Applications 15-SP2

An update that fixes three vulnerabilities is now available.

Description:

This update for openexr fixes the following issues:

  • CVE-2021-3474: Undefined-shift in Imf_2_5::FastHufDecoder::FastHufDecoder (bsc#1184174)
  • CVE-2021-3475: Integer-overflow in Imf_2_5::calculateNumTiles (bsc#1184173)
  • CVE-2021-3476: Undefined-shift in Imf_2_5::unpack14 (bsc#1184172)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Desktop Applications 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP2-2021-1097=1

Package List:

  • SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (aarch64 ppc64le s390x x86_64):
    • libIlmImf-2_2-23-2.2.1-3.24.1
    • libIlmImf-2_2-23-debuginfo-2.2.1-3.24.1
    • libIlmImfUtil-2_2-23-2.2.1-3.24.1
    • libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.24.1
    • openexr-debuginfo-2.2.1-3.24.1
    • openexr-debugsource-2.2.1-3.24.1
    • openexr-devel-2.2.1-3.24.1

References: