Recommended update for supportutils

SUSE Recommended Update: Recommended update for supportutils
Announcement ID: SUSE-RU-2021:1551-1
Rating: moderate
References: #1021918 #1043601 #1051419 #1063765 #1089870 #1127734 #1169348 #1179188 #1181351 #1184828 #1184911
Affected Products:
  • SUSE OpenStack Cloud Crowbar 9
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 9
  • SUSE OpenStack Cloud 8
  • SUSE Linux Enterprise Server for SAP 12-SP4
  • SUSE Linux Enterprise Server for SAP 12-SP3
  • SUSE Linux Enterprise Server 12-SP5
  • SUSE Linux Enterprise Server 12-SP4-LTSS
  • SUSE Linux Enterprise Server 12-SP3-LTSS
  • SUSE Linux Enterprise Server 12-SP3-BCL
  • SUSE Linux Enterprise Server 12-SP2-LTSS-SAP
  • SUSE Linux Enterprise Server 12-SP2-LTSS-ERICSSON
  • SUSE Linux Enterprise Server 12-SP2-BCL
  • HPE Helion Openstack 8

An update that has 11 recommended fixes can now be installed.

Description:

This update for supportutils fixes the following issues:

  • Performance improvements on large systems (bsc#1127734)
  • Added a check for package signatures in rpm.txt (bsc#1021918)
  • Performance improvements when the 'find' command is being used (bsc#1184911)
  • Fixed a bug where the updates.txt file did not list products in XML format anymore (bsc#1181351)
  • Fixed a bug where listing files under /sys fails when their names contain a backslash (bsc#1089870)
  • Added drbd information and configuration details to drbd.txt (bsc#1063765)
  • Added list-timers and list-jobs to systemd.txt (bsc#1169348)
  • Fixed a bug where supportconfig only searched for nfs, but not for nfs4 in /etc/fstab (bsc#1184828)
  • Added support for capturing rotated logs with different compression methods (bsc#1179188)
  • Removed deprecated mii-tool (bsc#1043601)
  • Added -u for HTTPS and -a for FTPES uploads to SUSE FTP servers (bsc#1051419)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 9:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-1551=1
  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2021-1551=1
  • SUSE OpenStack Cloud 9:
    zypper in -t patch SUSE-OpenStack-Cloud-9-2021-1551=1
  • SUSE OpenStack Cloud 8:
    zypper in -t patch SUSE-OpenStack-Cloud-8-2021-1551=1
  • SUSE Linux Enterprise Server for SAP 12-SP4:
    zypper in -t patch SUSE-SLE-SAP-12-SP4-2021-1551=1
  • SUSE Linux Enterprise Server for SAP 12-SP3:
    zypper in -t patch SUSE-SLE-SAP-12-SP3-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP4-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP3-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP3-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS-SAP:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-LTSS-SAP-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS-ERICSSON:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-LTSS-ERICSSON-2021-1551=1
  • SUSE Linux Enterprise Server 12-SP2-BCL:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2021-1551=1
  • HPE Helion Openstack 8:
    zypper in -t patch HPE-Helion-OpenStack-8-2021-1551=1

Package List:

  • SUSE OpenStack Cloud Crowbar 9 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE OpenStack Cloud Crowbar 8 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE OpenStack Cloud 9 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE OpenStack Cloud 8 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server for SAP 12-SP4 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server for SAP 12-SP3 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP5 (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP4-LTSS (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP3-LTSS (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP3-BCL (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS-SAP (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS-ERICSSON (noarch):
    • supportutils-3.0.9-95.45.1
  • SUSE Linux Enterprise Server 12-SP2-BCL (noarch):
    • supportutils-3.0.9-95.45.1
  • HPE Helion Openstack 8 (noarch):
    • supportutils-3.0.9-95.45.1

References: