Security update for xen

SUSE Security Update: Security update for xen
Announcement ID: SUSE-SU-2020:3615-1
Rating: important
References: #1177409 #1177412 #1177413 #1177414 #1178591 #1178963
Cross-References:CVE-2020-27670 CVE-2020-27671 CVE-2020-27672 CVE-2020-27674 CVE-2020-28368
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP2
  • SUSE Linux Enterprise Module for Basesystem 15-SP2

An update that solves 5 vulnerabilities and has one errata is now available.

Description:

This update for xen fixes the following issues:

  • bsc#1178963 - VUL-0: xen: stack corruption from XSA-346 change (XSA-355)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP2-2020-3615=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP2:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2020-3615=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP2 (noarch):
    • xen-tools-xendomains-wait-disk-4.13.2_04-3.19.1
  • SUSE Linux Enterprise Module for Server Applications 15-SP2 (x86_64):
    • xen-4.13.2_04-3.19.1
    • xen-debugsource-4.13.2_04-3.19.1
    • xen-devel-4.13.2_04-3.19.1
    • xen-tools-4.13.2_04-3.19.1
    • xen-tools-debuginfo-4.13.2_04-3.19.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP2 (x86_64):
    • xen-debugsource-4.13.2_04-3.19.1
    • xen-libs-4.13.2_04-3.19.1
    • xen-libs-debuginfo-4.13.2_04-3.19.1
    • xen-tools-domU-4.13.2_04-3.19.1
    • xen-tools-domU-debuginfo-4.13.2_04-3.19.1

References: