Security update for LibVNCServer

SUSE Security Update: Security update for LibVNCServer
Announcement ID: SUSE-SU-2020:14355-1
Rating: important
References: #1155419 #1160471 #1170441
Cross-References:CVE-2019-15681 CVE-2019-15690 CVE-2019-20788
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-LTSS
  • SUSE Linux Enterprise Point of Sale 11-SP3
  • SUSE Linux Enterprise Debuginfo 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP3

An update that fixes three vulnerabilities is now available.

Description:

This update for LibVNCServer fixes the following issues:

  • CVE-2019-15690: Fixed a heap buffer overflow (bsc#1160471).
  • CVE-2019-15681: Fixed a memory leak which could have allowed to a remote attacker to read stack memory (bsc#1155419).
  • CVE-2019-20788: Fixed a integer overflow and heap-based buffer overflow via a large height or width value (bsc#1170441).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-LTSS:
    zypper in -t patch slessp4-LibVNCServer-14355=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-LibVNCServer-14355=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-LibVNCServer-14355=1
  • SUSE Linux Enterprise Debuginfo 11-SP3:
    zypper in -t patch dbgsp3-LibVNCServer-14355=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-LTSS (i586 ppc64 s390x x86_64):
    • LibVNCServer-0.9.1-160.14.1
  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • LibVNCServer-0.9.1-160.14.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • LibVNCServer-debuginfo-0.9.1-160.14.1
    • LibVNCServer-debugsource-0.9.1-160.14.1
  • SUSE Linux Enterprise Debuginfo 11-SP3 (i586 s390x x86_64):
    • LibVNCServer-debuginfo-0.9.1-160.14.1
    • LibVNCServer-debugsource-0.9.1-160.14.1

References: