Security update for openconnect

SUSE Security Update: Security update for openconnect
Announcement ID: SUSE-SU-2020:1264-1
Rating: moderate
References: #1142093 #1170452
Cross-References:CVE-2020-12105
Affected Products:
  • SUSE Linux Enterprise Workstation Extension 12-SP5
  • SUSE Linux Enterprise Workstation Extension 12-SP4

An update that solves one vulnerability and has one errata is now available.

Description:

This update for openconnect fixes the following issue:
Security issue fixed:

  • CVE-2020-12105: Fixed the improper handling of negative return values from X509_check_ function calls that might have allowed MITM attacks (bsc#1170452).

Non-security issue fixed:
  • This is a rebuild to have a higher version than openconnect on Packagehub, to avoid having a vpnc dependency. (bsc#1142093)
  • A vpnc-script is included in this openconnect package.

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Workstation Extension 12-SP5:
    zypper in -t patch SUSE-SLE-WE-12-SP5-2020-1264=1
  • SUSE Linux Enterprise Workstation Extension 12-SP4:
    zypper in -t patch SUSE-SLE-WE-12-SP4-2020-1264=1

Package List:

  • SUSE Linux Enterprise Workstation Extension 12-SP5 (x86_64):
    • openconnect-7.08-3.9.1
    • openconnect-debuginfo-7.08-3.9.1
    • openconnect-debugsource-7.08-3.9.1
  • SUSE Linux Enterprise Workstation Extension 12-SP5 (noarch):
    • openconnect-lang-7.08-3.9.1
  • SUSE Linux Enterprise Workstation Extension 12-SP4 (noarch):
    • openconnect-lang-7.08-3.9.1
  • SUSE Linux Enterprise Workstation Extension 12-SP4 (x86_64):
    • openconnect-7.08-3.9.1
    • openconnect-debuginfo-7.08-3.9.1
    • openconnect-debugsource-7.08-3.9.1

References: