Security update for nodejs6

SUSE Security Update: Security update for nodejs6
Announcement ID: SUSE-SU-2020:0247-1
Rating: important
References: #1159352
Cross-References:CVE-2019-16775 CVE-2019-16776 CVE-2019-16777
Affected Products:
  • SUSE OpenStack Cloud Crowbar 9
  • SUSE OpenStack Cloud Crowbar 8
  • SUSE OpenStack Cloud 7
  • SUSE Linux Enterprise Module for Web Scripting 12

An update that fixes three vulnerabilities is now available.

Description:

This update for nodejs6 to version 6.17.1 fixes the following issues:
Security issues fixed:

  • CVE-2019-16777, CVE-2019-16776, CVE-2019-16775: Updated npm to 6.13.4, fixing an arbitrary path overwrite and access via "bin" field (bsc#1159352).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE OpenStack Cloud Crowbar 9:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2020-247=1
  • SUSE OpenStack Cloud Crowbar 8:
    zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2020-247=1
  • SUSE OpenStack Cloud 7:
    zypper in -t patch SUSE-OpenStack-Cloud-7-2020-247=1
  • SUSE Linux Enterprise Module for Web Scripting 12:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-12-2020-247=1

Package List:

  • SUSE OpenStack Cloud Crowbar 9 (x86_64):
    • nodejs6-6.17.1-11.30.1
    • nodejs6-debuginfo-6.17.1-11.30.1
    • nodejs6-debugsource-6.17.1-11.30.1
  • SUSE OpenStack Cloud Crowbar 8 (x86_64):
    • nodejs6-6.17.1-11.30.1
    • nodejs6-debuginfo-6.17.1-11.30.1
    • nodejs6-debugsource-6.17.1-11.30.1
  • SUSE OpenStack Cloud 7 (aarch64 s390x x86_64):
    • nodejs6-6.17.1-11.30.1
    • nodejs6-debuginfo-6.17.1-11.30.1
    • nodejs6-debugsource-6.17.1-11.30.1
  • SUSE Linux Enterprise Module for Web Scripting 12 (aarch64 ppc64le s390x x86_64):
    • nodejs6-6.17.1-11.30.1
    • nodejs6-debuginfo-6.17.1-11.30.1
    • nodejs6-debugsource-6.17.1-11.30.1
    • nodejs6-devel-6.17.1-11.30.1
    • npm6-6.17.1-11.30.1
  • SUSE Linux Enterprise Module for Web Scripting 12 (noarch):
    • nodejs6-docs-6.17.1-11.30.1

References: