Recommended update for corosync

SUSE Recommended Update: Recommended update for corosync
Announcement ID: SUSE-RU-2020:1093-1
Rating: important
References: #1168771
Affected Products:
  • SUSE Linux Enterprise High Availability 15

An update that has one recommended fix can now be installed.

Description:

This update for corosync fixes the following issues:

  • Revert the change done for bsc#1163460, which caused interoperability problems between different versions of corosync, such as during a rolling upgrade (bsc#1168771)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15:
    zypper in -t patch SUSE-SLE-Product-HA-15-2020-1093=1

Package List:

  • SUSE Linux Enterprise High Availability 15 (aarch64 ppc64le s390x x86_64):
    • corosync-2.4.4-5.6.1
    • corosync-debuginfo-2.4.4-5.6.1
    • corosync-debugsource-2.4.4-5.6.1
    • corosync-qdevice-2.4.4-5.6.1
    • corosync-qdevice-debuginfo-2.4.4-5.6.1
    • corosync-qnetd-2.4.4-5.6.1
    • corosync-qnetd-debuginfo-2.4.4-5.6.1
    • corosync-testagents-2.4.4-5.6.1
    • corosync-testagents-debuginfo-2.4.4-5.6.1
    • libcfg6-2.4.4-5.6.1
    • libcfg6-debuginfo-2.4.4-5.6.1
    • libcmap4-2.4.4-5.6.1
    • libcmap4-debuginfo-2.4.4-5.6.1
    • libcorosync-devel-2.4.4-5.6.1
    • libcorosync_common4-2.4.4-5.6.1
    • libcorosync_common4-debuginfo-2.4.4-5.6.1
    • libcpg4-2.4.4-5.6.1
    • libcpg4-debuginfo-2.4.4-5.6.1
    • libquorum5-2.4.4-5.6.1
    • libquorum5-debuginfo-2.4.4-5.6.1
    • libsam4-2.4.4-5.6.1
    • libsam4-debuginfo-2.4.4-5.6.1
    • libtotem_pg5-2.4.4-5.6.1
    • libtotem_pg5-debuginfo-2.4.4-5.6.1
    • libvotequorum8-2.4.4-5.6.1
    • libvotequorum8-debuginfo-2.4.4-5.6.1

References: