Recommended update for perl-CGI

SUSE Recommended Update: Recommended update for perl-CGI
Announcement ID: SUSE-RU-2020:1033-1
Rating: moderate
References: #1162868
Affected Products:
  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for perl-CGI fixes the following issues:
Update from version 4.38 to 4.46 (bsc#1162868)

  • Add support for SameSite=None cookies and update the documentation
  • Replace only use of "base" with "parent" given that CGI already depends on "parent"
  • Support unquoted multipart/form-data name values
  • Update the package license from "Artistic-1.0 or GPL-1.0+" to "Artistic-2.0"
  • Support perls < 5.10.1 and specify CONFIGURE_REQUIRES in Makefile.PL for being more dynamic

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-SP1-2020-1033=1

Package List:

  • SUSE Linux Enterprise Module for Desktop Applications 15-SP1 (noarch):
    • perl-CGI-4.46-3.3.1

References: