Recommended update for mariadb-connector-c

SUSE Recommended Update: Recommended update for mariadb-connector-c
Announcement ID: SUSE-RU-2020:0563-1
Rating: moderate
References: #1162388
Affected Products:
  • SUSE Linux Enterprise Server 12-SP5
  • SUSE Linux Enterprise Server 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for mariadb-connector-c fixes the following issues:
New upstream version 3.1.7 (bsc#1162388)

  • TLS/SSL: when the client doesn't provide a CA file and the option ssl_verify_server_cert was set, the peer certificate will be validated against the system CA.
  • ERROR 2026 (HY000): SSL connection error due to Certificate signature check failed
  • Provide error code and message for SChannel errors
  • SEC_E_INVALID_TOKEN when server sends large message during SSL handshake

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-563=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2020-563=1

Package List:

  • SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):
    • libmariadb3-3.1.7-2.12.1
    • libmariadb3-debuginfo-3.1.7-2.12.1
    • libmariadb_plugins-3.1.7-2.12.1
    • libmariadb_plugins-debuginfo-3.1.7-2.12.1
    • mariadb-connector-c-debugsource-3.1.7-2.12.1
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libmariadb3-3.1.7-2.12.1
    • libmariadb3-debuginfo-3.1.7-2.12.1
    • libmariadb_plugins-3.1.7-2.12.1
    • libmariadb_plugins-debuginfo-3.1.7-2.12.1
    • mariadb-connector-c-debugsource-3.1.7-2.12.1

References: