Recommended update for 389-ds

SUSE Recommended Update: Recommended update for 389-ds
Announcement ID: SUSE-RU-2020:0556-1
Rating: moderate
References: #1155951
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP1
  • SUSE Linux Enterprise Module for Public Cloud 15-SP1
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for 389-ds to version 1.4.2.2 fixes the following issues:
389-ds was updated to 1.4.2.6 (fate#326677, bsc#1155951), bringing many bug and stability fixes.
Issue addressed:

  • Enabled python lib389 installer tooling to match upstream and suse documentation.

More information for this release at: https://directory.fedoraproject.org/docs/389ds/releases/release-1-4-2-1.htm l

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2020-556=1
  • SUSE Linux Enterprise Module for Public Cloud 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-SP1-2020-556=1
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-556=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-556=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-556=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    • 389-ds-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-debuginfo-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-debugsource-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-devel-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-snmp-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-snmp-debuginfo-1.4.2.6~git0.e84bbce3f-7.8.1
    • lib389-1.4.2.6~git0.e84bbce3f-7.8.1
    • libsvrcore0-1.4.2.6~git0.e84bbce3f-7.8.1
    • libsvrcore0-debuginfo-1.4.2.6~git0.e84bbce3f-7.8.1
    • python3-argparse-manpage-1.2.2-1.4.3
    • python3-ldap-3.1.0-3.2.20
    • python3-ldap-debuginfo-3.1.0-3.2.20
  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (noarch):
    • python3-argcomplete-1.9.2-3.2.14
    • python3-wheel-0.32.3-6.2.12
  • SUSE Linux Enterprise Module for Public Cloud 15-SP1 (noarch):
    • python3-argcomplete-1.9.2-3.2.14
    • python3-wheel-0.32.3-6.2.12
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-ldap-debuginfo-3.1.0-3.2.20
    • python-ldap-debugsource-3.1.0-3.2.20
    • python2-ldap-3.1.0-3.2.20
    • python2-ldap-debuginfo-3.1.0-3.2.20
  • SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1 (noarch):
    • python2-wheel-0.32.3-6.2.12
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • 389-ds-debuginfo-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-debugsource-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-snmp-1.4.2.6~git0.e84bbce3f-7.8.1
    • 389-ds-snmp-debuginfo-1.4.2.6~git0.e84bbce3f-7.8.1
    • python-ldap-debuginfo-3.1.0-3.2.20
    • python-ldap-debugsource-3.1.0-3.2.20
    • python2-ldap-3.1.0-3.2.20
    • python2-ldap-debuginfo-3.1.0-3.2.20
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    • python2-argcomplete-1.9.2-3.2.14
    • python2-pyasn1-modules-0.2.1-3.4.12
    • python2-wheel-0.32.3-6.2.12
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-ldap-debuginfo-3.1.0-3.2.20
    • python-ldap-debugsource-3.1.0-3.2.20
    • python3-ldap-3.1.0-3.2.20
    • python3-ldap-debuginfo-3.1.0-3.2.20
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (noarch):
    • python3-pyasn1-modules-0.2.1-3.4.12
    • yast2-auth-server-4.1.1-6.3.4

References: