Recommended update for pam

SUSE Recommended Update: Recommended update for pam
Announcement ID: SUSE-RU-2020:0525-1
Rating: moderate
References: #1164562
Affected Products:
  • SUSE Linux Enterprise Module for Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for pam fixes the following issues:

  • Add libdb as build-time dependency to enable pam_userdb module. Enable pam_userdb.so (jsc#sle-7258, bsc#1164562)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2020-525=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-525=1

Package List:

  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (x86_64):
    • pam-32bit-debuginfo-1.3.0-6.9.2
    • pam-debugsource-1.3.0-6.9.2
    • pam-devel-32bit-1.3.0-6.9.2
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • pam-1.3.0-6.9.2
    • pam-debuginfo-1.3.0-6.9.2
    • pam-debugsource-1.3.0-6.9.2
    • pam-devel-1.3.0-6.9.2
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (noarch):
    • pam-doc-1.3.0-6.9.2
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (x86_64):
    • pam-32bit-1.3.0-6.9.2
    • pam-32bit-debuginfo-1.3.0-6.9.2

References: