Recommended update for libgcrypt

SUSE Recommended Update: Recommended update for libgcrypt
Announcement ID: SUSE-RU-2020:0156-1
Rating: moderate
References: #1161215 #1161216 #1161218 #1161219 #1161220
Affected Products:
  • SUSE Linux Enterprise Server for SAP 15
  • SUSE Linux Enterprise Server 15-LTSS
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15
  • SUSE Linux Enterprise High Performance Computing 15-LTSS
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS

An update that has 5 recommended fixes can now be installed.

Description:

This update for libgcrypt fixes the following issues:

  • ECDSA: Check range of coordinates (bsc#1161216)
  • FIPS: libgcrypt DSA PQG parameter generation: Missing value (bsc#1161219)
  • FIPS: libgcrypt DSA PQG verification incorrect results (bsc#1161215)
  • FIPS: libgcrypt RSA siggen/keygen: 4k not supported (bsc#1161220)
  • FIPS: keywrap gives incorrect results (bsc#1161218)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 15:
    zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-156=1
  • SUSE Linux Enterprise Server 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-SLES-15-2020-156=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2020-156=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2020-156=1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-156=1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS:
    zypper in -t patch SUSE-SLE-Product-HPC-15-2020-156=1

Package List:

  • SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):
    • libgcrypt-debugsource-1.8.2-6.26.1
    • libgcrypt-devel-1.8.2-6.26.1
    • libgcrypt-devel-debuginfo-1.8.2-6.26.1
    • libgcrypt20-1.8.2-6.26.1
    • libgcrypt20-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-1.8.2-6.26.1
  • SUSE Linux Enterprise Server for SAP 15 (x86_64):
    • libgcrypt20-32bit-1.8.2-6.26.1
    • libgcrypt20-32bit-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-32bit-1.8.2-6.26.1
  • SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):
    • libgcrypt-debugsource-1.8.2-6.26.1
    • libgcrypt-devel-1.8.2-6.26.1
    • libgcrypt-devel-debuginfo-1.8.2-6.26.1
    • libgcrypt20-1.8.2-6.26.1
    • libgcrypt20-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-1.8.2-6.26.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • libgcrypt-cavs-1.8.2-6.26.1
    • libgcrypt-cavs-debuginfo-1.8.2-6.26.1
    • libgcrypt-debugsource-1.8.2-6.26.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libgcrypt-debugsource-1.8.2-6.26.1
    • libgcrypt-devel-1.8.2-6.26.1
    • libgcrypt-devel-debuginfo-1.8.2-6.26.1
    • libgcrypt20-1.8.2-6.26.1
    • libgcrypt20-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-1.8.2-6.26.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • libgcrypt20-32bit-1.8.2-6.26.1
    • libgcrypt20-32bit-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-32bit-1.8.2-6.26.1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):
    • libgcrypt-debugsource-1.8.2-6.26.1
    • libgcrypt-devel-1.8.2-6.26.1
    • libgcrypt-devel-debuginfo-1.8.2-6.26.1
    • libgcrypt20-1.8.2-6.26.1
    • libgcrypt20-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-1.8.2-6.26.1
  • SUSE Linux Enterprise High Performance Computing 15-LTSS (x86_64):
    • libgcrypt20-32bit-1.8.2-6.26.1
    • libgcrypt20-32bit-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-32bit-1.8.2-6.26.1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64 x86_64):
    • libgcrypt-debugsource-1.8.2-6.26.1
    • libgcrypt-devel-1.8.2-6.26.1
    • libgcrypt-devel-debuginfo-1.8.2-6.26.1
    • libgcrypt20-1.8.2-6.26.1
    • libgcrypt20-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-1.8.2-6.26.1
  • SUSE Linux Enterprise High Performance Computing 15-ESPOS (x86_64):
    • libgcrypt20-32bit-1.8.2-6.26.1
    • libgcrypt20-32bit-debuginfo-1.8.2-6.26.1
    • libgcrypt20-hmac-32bit-1.8.2-6.26.1

References: