Recommended update for suse-migration-sle15-activation

SUSE Recommended Update: Recommended update for suse-migration-sle15-activation
Announcement ID: SUSE-RU-2020:0033-1
Rating: moderate
References: #1155192
Affected Products:
  • SUSE Linux Enterprise Module for Public Cloud 12

An update that has one recommended fix can now be installed.

Description:

This update for suse-migration-sle15-activation contains the following fixes:

  • Migration failures from SLES12SP4 to SLES15SP1. (bsc#1155192)

  • Add requires for minimun version: Boolean expressions are available with rpm >= 4.13 and SLES_SAP provides product(SLES) = %{version}-%{release}

  • Disable use of bool expressions in Requires: Available with rpm >= 4.13. Thus we can't build for SLE12 because rpm is older there

  • Fixed Requires syntax: boolean expressions must be embedded into brackets According to https://rpm.org/user_doc/more_dependencies.html

  • Add OR condition properly

  • The minimum migration starting point should be: SLES 12 SP3 or SLES For SAP 12 SP3.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Public Cloud 12:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-12-2020-33=1

Package List:

  • SUSE Linux Enterprise Module for Public Cloud 12 (noarch):
    • suse-migration-sle15-activation-1.2.0-6.11.3

References: