Recommended update for rdma-core

SUSE Recommended Update: Recommended update for rdma-core
Announcement ID: SUSE-RU-2020:0027-1
Rating: moderate
References: #1137131 #1137132 #1140601 #1157891
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that has four recommended fixes can now be installed.

Description:

This update for rdma-core fixes the following issues:

  • Add Broadcom fixes for libbnxtre. (bsc#1157891)
  • Disable libmlx dependencies for libibverbs on s390x 32 bits. (bsc#1140601)
  • Fix baselibs configuration removing conflict with -32b and older (early rdma-core) libraries.
  • Add missing Obsoletes/Conflicts/Provides to handle updates from SP2. (bsc#1137131, bsc#1137132)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2020-27=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-27=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-27=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    • ibacm-22.5-4.6.1
    • ibacm-debuginfo-22.5-4.6.1
    • iwpmd-22.5-4.6.1
    • iwpmd-debuginfo-22.5-4.6.1
    • libibverbs-utils-22.5-4.6.1
    • libibverbs-utils-debuginfo-22.5-4.6.1
    • librdmacm-utils-22.5-4.6.1
    • librdmacm-utils-debuginfo-22.5-4.6.1
    • rdma-core-debugsource-22.5-4.6.1
    • rdma-ndd-22.5-4.6.1
    • rdma-ndd-debuginfo-22.5-4.6.1
    • srp_daemon-22.5-4.6.1
    • srp_daemon-debuginfo-22.5-4.6.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • libibumad3-32bit-22.5-4.6.1
    • libibumad3-32bit-debuginfo-22.5-4.6.1
    • libibverbs-32bit-22.5-4.6.1
    • libibverbs-32bit-debuginfo-22.5-4.6.1
    • libibverbs1-32bit-22.5-4.6.1
    • libibverbs1-32bit-debuginfo-22.5-4.6.1
    • libmlx4-1-32bit-22.5-4.6.1
    • libmlx4-1-32bit-debuginfo-22.5-4.6.1
    • libmlx5-1-32bit-22.5-4.6.1
    • libmlx5-1-32bit-debuginfo-22.5-4.6.1
    • librdmacm1-32bit-22.5-4.6.1
    • librdmacm1-32bit-debuginfo-22.5-4.6.1
    • rdma-core-debugsource-22.5-4.6.1
    • rdma-core-devel-32bit-22.5-4.6.1
    • rsocket-32bit-22.5-4.6.1
    • rsocket-32bit-debuginfo-22.5-4.6.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libibumad3-22.5-4.6.1
    • libibumad3-debuginfo-22.5-4.6.1
    • libibverbs-22.5-4.6.1
    • libibverbs-debuginfo-22.5-4.6.1
    • libibverbs1-22.5-4.6.1
    • libibverbs1-debuginfo-22.5-4.6.1
    • libmlx4-1-22.5-4.6.1
    • libmlx4-1-debuginfo-22.5-4.6.1
    • libmlx5-1-22.5-4.6.1
    • libmlx5-1-debuginfo-22.5-4.6.1
    • librdmacm1-22.5-4.6.1
    • librdmacm1-debuginfo-22.5-4.6.1
    • rdma-core-22.5-4.6.1
    • rdma-core-debugsource-22.5-4.6.1
    • rdma-core-devel-22.5-4.6.1
    • rsocket-22.5-4.6.1
    • rsocket-debuginfo-22.5-4.6.1

References: