Security update for libarchive

SUSE Security Update: Security update for libarchive
Announcement ID: SUSE-SU-2019:3093-1
Rating: moderate
References: #1120653 #1120654 #1124341 #1124342 #1155079
Cross-References: CVE-2018-1000877 CVE-2018-1000878 CVE-2019-1000019 CVE-2019-1000020 CVE-2019-18408
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes 5 vulnerabilities is now available.

Description:

This update for libarchive fixes the following issues:
Security issues fixed:

  • CVE-2018-1000877: Fixed a double free vulnerability in RAR decoder (bsc#1120653).
  • CVE-2018-1000878: Fixed a Use-After-Free vulnerability in RAR decoder (bsc#1120654).
  • CVE-2019-1000019: Fixed an Out-Of-Bounds Read vulnerability in 7zip decompression (bsc#1124341).
  • CVE-2019-1000020: Fixed an Infinite Loop vulnerability in ISO9660 parser (bsc#1124342).
  • CVE-2019-18408: Fixed a use-after-free in RAR format support (bsc#1155079).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-3093=1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2019-3093=1
  • SUSE Linux Enterprise Module for Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-2019-3093=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-3093=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-3093=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • libarchive-debugsource-3.3.2-3.11.1
    • libarchive13-32bit-3.3.2-3.11.1
    • libarchive13-32bit-debuginfo-3.3.2-3.11.1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • bsdtar-3.3.2-3.11.1
    • bsdtar-debuginfo-3.3.2-3.11.1
    • libarchive-debugsource-3.3.2-3.11.1
  • SUSE Linux Enterprise Module for Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • bsdtar-3.3.2-3.11.1
    • bsdtar-debuginfo-3.3.2-3.11.1
    • libarchive-debugsource-3.3.2-3.11.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libarchive-debugsource-3.3.2-3.11.1
    • libarchive-devel-3.3.2-3.11.1
    • libarchive13-3.3.2-3.11.1
    • libarchive13-debuginfo-3.3.2-3.11.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libarchive-debugsource-3.3.2-3.11.1
    • libarchive-devel-3.3.2-3.11.1
    • libarchive13-3.3.2-3.11.1
    • libarchive13-debuginfo-3.3.2-3.11.1

References: