Security update for slurm

SUSE Security Update: Security update for slurm
Announcement ID: SUSE-SU-2019:3080-1
Rating: moderate
References: #1123304 #1140709
Cross-References: CVE-2019-12838 CVE-2019-6438
Affected Products:
  • SUSE Linux Enterprise Module for HPC 12

An update that fixes two vulnerabilities is now available.

Description:

This update for slurm fixes the following issues:
Security issue fixed:

  • CVE-2019-6438: Fixed a heap overflow on 32-bit systems in xmalloc (bsc#1123304).
  • CVE-2019-12838: Fixed an SQL injection (bsc#1140709).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for HPC 12:
    zypper in -t patch SUSE-SLE-Module-HPC-12-2019-3080=1

Package List:

  • SUSE Linux Enterprise Module for HPC 12 (aarch64 x86_64):
    • libpmi0-17.02.11-6.33.1
    • libpmi0-debuginfo-17.02.11-6.33.1
    • libslurm31-17.02.11-6.33.1
    • libslurm31-debuginfo-17.02.11-6.33.1
    • perl-slurm-17.02.11-6.33.1
    • perl-slurm-debuginfo-17.02.11-6.33.1
    • slurm-17.02.11-6.33.1
    • slurm-auth-none-17.02.11-6.33.1
    • slurm-auth-none-debuginfo-17.02.11-6.33.1
    • slurm-config-17.02.11-6.33.1
    • slurm-debuginfo-17.02.11-6.33.1
    • slurm-debugsource-17.02.11-6.33.1
    • slurm-devel-17.02.11-6.33.1
    • slurm-doc-17.02.11-6.33.1
    • slurm-lua-17.02.11-6.33.1
    • slurm-lua-debuginfo-17.02.11-6.33.1
    • slurm-munge-17.02.11-6.33.1
    • slurm-munge-debuginfo-17.02.11-6.33.1
    • slurm-pam_slurm-17.02.11-6.33.1
    • slurm-pam_slurm-debuginfo-17.02.11-6.33.1
    • slurm-plugins-17.02.11-6.33.1
    • slurm-plugins-debuginfo-17.02.11-6.33.1
    • slurm-sched-wiki-17.02.11-6.33.1
    • slurm-slurmdb-direct-17.02.11-6.33.1
    • slurm-slurmdbd-17.02.11-6.33.1
    • slurm-slurmdbd-debuginfo-17.02.11-6.33.1
    • slurm-sql-17.02.11-6.33.1
    • slurm-sql-debuginfo-17.02.11-6.33.1
    • slurm-torque-17.02.11-6.33.1
    • slurm-torque-debuginfo-17.02.11-6.33.1

References: