Security update for libssh2_org

SUSE Security Update: Security update for libssh2_org
Announcement ID: SUSE-SU-2019:2900-1
Rating: moderate
References: #1154862
Cross-References: CVE-2019-17498
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes one vulnerability is now available.

Description:

This update for libssh2_org fixes the following issue:

  • CVE-2019-17498: Fixed an integer overflow in a bounds check that might have led to the disclosure of sensitive information or a denial of service (bsc#1154862).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2900=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2900=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-2900=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • libssh2-1-32bit-1.8.0-4.10.1
    • libssh2-1-32bit-debuginfo-1.8.0-4.10.1
    • libssh2_org-debugsource-1.8.0-4.10.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libssh2-1-1.8.0-4.10.1
    • libssh2-1-debuginfo-1.8.0-4.10.1
    • libssh2-devel-1.8.0-4.10.1
    • libssh2_org-debugsource-1.8.0-4.10.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libssh2-1-1.8.0-4.10.1
    • libssh2-1-debuginfo-1.8.0-4.10.1
    • libssh2-devel-1.8.0-4.10.1
    • libssh2_org-debugsource-1.8.0-4.10.1

References: