Security update for the Linux Kernel (Live Patch 32 for SLE 12 SP2)

SUSE Security Update: Security update for the Linux Kernel (Live Patch 32 for SLE 12 SP2)
Announcement ID: SUSE-SU-2019:2601-1
Rating: important
References: #1102682 #1151021
Cross-References: CVE-2018-5390 CVE-2019-14835
Affected Products:
  • SUSE Linux Enterprise Server for SAP 12-SP2
  • SUSE Linux Enterprise Server 12-SP2-LTSS

An update that fixes two vulnerabilities is now available.

Description:

This update for the Linux Kernel 4.4.121-92_120 fixes several issues.
The following security issues were fixed:

  • CVE-2019-14835: A buffer overflow flaw was found in the way vhost functionality, that translates virtqueue buffers to IOVs, logged the buffer descriptors during migration. A privileged guest user able to pass descriptors with invalid length to the host when migration is underway, could use this flaw to increase their privileges on the host (bsc#1151021).
  • CVE-2018-5390: Fixed a denial of service ("SegmentSmack") in tcp_collapse_ofo_queue() and tcp_prune_ofo_queue() for every incoming packet (bsc#1102682).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server for SAP 12-SP2:
    zypper in -t patch SUSE-SLE-SAP-12-SP2-2019-2601=1
  • SUSE Linux Enterprise Server 12-SP2-LTSS:
    zypper in -t patch SUSE-SLE-SERVER-12-SP2-2019-2601=1

Package List:

  • SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):
    • kgraft-patch-4_4_121-92_120-default-2-2.1
  • SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le x86_64):
    • kgraft-patch-4_4_121-92_120-default-2-2.1

References: