Security update for tomcat

SUSE Security Update: Security update for tomcat
Announcement ID: SUSE-SU-2019:1866-1
Rating: moderate
References: #1131055 #1136085 #1139924
Cross-References: CVE-2019-0199 CVE-2019-0221 CVE-2019-10072
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4

An update that fixes three vulnerabilities is now available.

Description:

This update for tomcat to version 9.0.21 fixes the following issues:
Security issues fixed:

  • CVE-2019-0199: Fixed a denial of service in the HTTP/2 implementation related to streams with excessive numbers of SETTINGS frames (bsc#1131055).
  • CVE-2019-0221: Fixed a cross site scripting vulnerability with the SSI printenv command (bsc#1136085).
  • CVE-2019-10072: Fixed incomplete patch for CVE-2019-0199 (bsc#1139924).

Please also see http://tomcat.apache.org/tomcat-9.0-doc/changelog.html#Tomcat_9.0.21_(markt ) and http://tomcat.apache.org/tomcat-9.0-doc/changelog.html#Tomcat_9.0.20_(markt )

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-1866=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • tomcat-9.0.21-3.13.2
    • tomcat-admin-webapps-9.0.21-3.13.2
    • tomcat-docs-webapp-9.0.21-3.13.2
    • tomcat-el-3_0-api-9.0.21-3.13.2
    • tomcat-javadoc-9.0.21-3.13.2
    • tomcat-jsp-2_3-api-9.0.21-3.13.2
    • tomcat-lib-9.0.21-3.13.2
    • tomcat-servlet-4_0-api-9.0.21-3.13.2
    • tomcat-webapps-9.0.21-3.13.2

References: