Security update for postgresql10

SUSE Security Update: Security update for postgresql10
Announcement ID: SUSE-SU-2019:1783-3
Rating: important
References: #1138034
Cross-References: CVE-2019-10164
Affected Products:
  • SUSE Enterprise Storage 5

An update that fixes one vulnerability is now available.

Description:

This update for postgresql10 to version 10.9 fixes the following issue:
Security issue fixed:

  • CVE-2019-10164: Fixed buffer-overflow vulnerabilities in SCRAM verifier parsing (bsc#1138034).

More information at https://www.postgresql.org/docs/10/release-10-9.html

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Enterprise Storage 5:
    zypper in -t patch SUSE-Storage-5-2019-1783=1

Package List:

  • SUSE Enterprise Storage 5 (aarch64):
    • libecpg6-10.9-1.12.1
    • libecpg6-debuginfo-10.9-1.12.1
    • libpq5-10.9-1.12.1
    • libpq5-debuginfo-10.9-1.12.1
    • postgresql10-10.9-1.12.2
    • postgresql10-contrib-10.9-1.12.2
    • postgresql10-contrib-debuginfo-10.9-1.12.2
    • postgresql10-debuginfo-10.9-1.12.2
    • postgresql10-debugsource-10.9-1.12.2
    • postgresql10-libs-debugsource-10.9-1.12.1
    • postgresql10-plperl-10.9-1.12.2
    • postgresql10-plperl-debuginfo-10.9-1.12.2
    • postgresql10-plpython-10.9-1.12.2
    • postgresql10-plpython-debuginfo-10.9-1.12.2
    • postgresql10-pltcl-10.9-1.12.2
    • postgresql10-pltcl-debuginfo-10.9-1.12.2
    • postgresql10-server-10.9-1.12.2
    • postgresql10-server-debuginfo-10.9-1.12.2
  • SUSE Enterprise Storage 5 (noarch):
    • postgresql10-docs-10.9-1.12.2

References: