Security update for tomcat

SUSE Security Update: Security update for tomcat
Announcement ID: SUSE-SU-2019:1693-1
Rating: moderate
References: #1111966 #1131055 #1136085
Cross-References: CVE-2019-0199 CVE-2019-0221
Affected Products:
  • SUSE Linux Enterprise Module for Web Scripting 15
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15

An update that solves two vulnerabilities and has one errata is now available.

Description:

This update for tomcat to version 9.0.20 fixes the following issues:
Security issues fixed:

  • CVE-2019-0199: Fixed a denial of service in the HTTP/2 implementation related to streams with excessive numbers of SETTINGS frames (bsc#1131055).
  • CVE-2019-0221: Fixed a cross site scripting vulnerability with the SSI printenv command (bsc#1136085).

Non-security issues fixed:
  • Increase maximum number of threads and open files for tomcat (bsc#1111966).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Web Scripting 15:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-2019-1693=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-1693=1

Package List:

  • SUSE Linux Enterprise Module for Web Scripting 15 (noarch):
    • tomcat-9.0.20-3.24.2
    • tomcat-admin-webapps-9.0.20-3.24.2
    • tomcat-el-3_0-api-9.0.20-3.24.2
    • tomcat-jsp-2_3-api-9.0.20-3.24.2
    • tomcat-lib-9.0.20-3.24.2
    • tomcat-servlet-4_0-api-9.0.20-3.24.2
    • tomcat-webapps-9.0.20-3.24.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • tomcat-docs-webapp-9.0.20-3.24.2
    • tomcat-embed-9.0.20-3.24.2
    • tomcat-javadoc-9.0.20-3.24.2
    • tomcat-jsvc-9.0.20-3.24.2

References: