Security update for dnsmasq

SUSE Security Update: Security update for dnsmasq
Announcement ID: SUSE-SU-2019:14190-1
Rating: moderate
References: #1076958 #1138743
Cross-References: CVE-2017-15107
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-LTSS
  • SUSE Linux Enterprise Debuginfo 11-SP4

An update that solves one vulnerability and has one errata is now available.

Description:

This update for dnsmasq fixes the following issues:
Security issue fixed:

  • CVE-2017-15107: Fixed a vulnerability in DNSSEC implementation. Processing of wildcard synthesized NSEC records may result improper validation for non-existance. (bsc#1076958)

Non-security issue fixed:
  • Removed cache size limit. (bsc#1138743)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-LTSS:
    zypper in -t patch slessp4-dnsmasq-14190=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-dnsmasq-14190=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-LTSS (i586 ppc64 s390x x86_64):
    • dnsmasq-2.78-0.17.10.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • dnsmasq-debuginfo-2.78-0.17.10.1
    • dnsmasq-debugsource-2.78-0.17.10.1

References: