Security update for supportutils

SUSE Security Update: Security update for supportutils
Announcement ID: SUSE-SU-2019:13976-1
Rating: moderate
References: #1117751 #1118460 #1118462 #1118463
Cross-References: CVE-2018-19636 CVE-2018-19638 CVE-2018-19639 CVE-2018-19640
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4
  • SUSE Linux Enterprise Point of Sale 11-SP3

An update that fixes four vulnerabilities is now available.

Description:

This update for supportutils fixes the following issues:
Security vulnerabilities fixed:

  • CVE-2018-19636: Local root exploit via inclusion of attacker controlled shell script (bsc#1117751)
  • CVE-2018-19640: Users can kill arbitrary processes (bsc#1118463)
  • CVE-2018-19638: User can overwrite arbitrary log files in support tar (bsc#1118460)
  • CVE-2018-19639: Code execution if run with -v (bsc#1118462)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4:
    zypper in -t patch slessp4-supportutils-13976=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-supportutils-13976=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4 (noarch):
    • supportutils-1.20-122.9.1
  • SUSE Linux Enterprise Point of Sale 11-SP3 (noarch):
    • supportutils-1.20-122.9.1

References: