Security update for sqlite3

SUSE Security Update: Security update for sqlite3
Announcement ID: SUSE-SU-2019:1127-1
Rating: moderate
References: #1130325 #1130326
Cross-References: CVE-2019-9936 CVE-2019-9937
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes two vulnerabilities is now available.

Description:

This update for sqlite3 to version 3.28.0 fixes the following issues:
Security issues fixed:

  • CVE-2019-9936: Fixed a heap-based buffer over-read, when running fts5 prefix queries inside transaction (bsc#1130326).
  • CVE-2019-9937: Fixed a denial of service related to interleaving reads and writes in a single transaction with an fts5 virtual table (bsc#1130325).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-1127=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-1127=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • sqlite3-doc-3.28.0-3.6.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • libsqlite3-0-3.28.0-3.6.1
    • libsqlite3-0-debuginfo-3.28.0-3.6.1
    • sqlite3-3.28.0-3.6.1
    • sqlite3-debuginfo-3.28.0-3.6.1
    • sqlite3-debugsource-3.28.0-3.6.1
    • sqlite3-devel-3.28.0-3.6.1
  • SUSE Linux Enterprise Module for Basesystem 15 (x86_64):
    • libsqlite3-0-32bit-3.28.0-3.6.1
    • libsqlite3-0-32bit-debuginfo-3.28.0-3.6.1

References: