Security update for openexr

SUSE Security Update: Security update for openexr
Announcement ID: SUSE-SU-2019:0954-1
Rating: low
References: #1113455
Cross-References: CVE-2018-18444
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15

An update that fixes one vulnerability is now available.

Description:

This update for openexr fixes the following issues:
Security issue fixed:

  • CVE-2018-18444: Fixed Out-of-bounds write in makeMultiView.cpp (bsc#1113455).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-954=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-954=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • openexr-2.2.1-3.3.11
    • openexr-debuginfo-2.2.1-3.3.11
    • openexr-debugsource-2.2.1-3.3.11
    • openexr-doc-2.2.1-3.3.11
  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • libIlmImf-2_2-23-2.2.1-3.3.11
    • libIlmImf-2_2-23-debuginfo-2.2.1-3.3.11
    • libIlmImfUtil-2_2-23-2.2.1-3.3.11
    • libIlmImfUtil-2_2-23-debuginfo-2.2.1-3.3.11
    • openexr-debuginfo-2.2.1-3.3.11
    • openexr-debugsource-2.2.1-3.3.11
    • openexr-devel-2.2.1-3.3.11

References: