Security update for flac

SUSE Security Update: Security update for flac
Announcement ID: SUSE-SU-2019:0920-1
Rating: low
References: #1091045
Cross-References: CVE-2017-6888
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes one vulnerability is now available.

Description:

This update for flac fixes the following issues:

  • CVE-2017-6888: An error in the "read_metadata_vorbiscomment_()" function could be exploited to cause a memory leak via a specially crafted FLAC file (bsc#1091045).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-920=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-920=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • flac-1.3.2-3.3.20
    • flac-debuginfo-1.3.2-3.3.20
    • flac-debugsource-1.3.2-3.3.20
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • flac-doc-1.3.2-3.3.20
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • flac-debuginfo-1.3.2-3.3.20
    • flac-debugsource-1.3.2-3.3.20
    • flac-devel-1.3.2-3.3.20
    • libFLAC++6-1.3.2-3.3.20
    • libFLAC++6-debuginfo-1.3.2-3.3.20
    • libFLAC8-1.3.2-3.3.20
    • libFLAC8-debuginfo-1.3.2-3.3.20

References: