Security update for gd

SUSE Security Update: Security update for gd
Announcement ID: SUSE-SU-2019:0771-1
Rating: moderate
References: #1123361 #1123522
Cross-References: CVE-2019-6977 CVE-2019-6978
Affected Products:
  • SUSE Linux Enterprise Module for Desktop Applications 15
  • SUSE Linux Enterprise Module for Basesystem 15

An update that fixes two vulnerabilities is now available.

Description:

This update for gd fixes the following issues:
Security issues fixed:

  • CVE-2019-6977: Fixed a heap-based buffer overflow the GD Graphics Library used in the imagecolormatch function (bsc#1123361).
  • CVE-2019-6978: Fixed a double free in the gdImage*Ptr() functions (bsc#1123522).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-771=1
  • SUSE Linux Enterprise Module for Basesystem 15:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-2019-771=1

Package List:

  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • gd-2.2.5-4.6.1
    • gd-debuginfo-2.2.5-4.6.1
    • gd-debugsource-2.2.5-4.6.1
    • gd-devel-2.2.5-4.6.1
  • SUSE Linux Enterprise Module for Basesystem 15 (aarch64 ppc64le s390x x86_64):
    • gd-debuginfo-2.2.5-4.6.1
    • gd-debugsource-2.2.5-4.6.1
    • libgd3-2.2.5-4.6.1
    • libgd3-debuginfo-2.2.5-4.6.1

References: