Security update for libgxps

SUSE Security Update: Security update for libgxps
Announcement ID: SUSE-SU-2019:0720-1
Rating: moderate
References: #1092125
Cross-References: CVE-2018-10733
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise Module for Desktop Applications 15

An update that fixes one vulnerability is now available.

Description:

This update for libgxps fixes the following issues:

  • CVE-2018-10733: Fixed a heap-based buffer over-read issue in ft_font_face_hash (bsc#1092125).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-720=1
  • SUSE Linux Enterprise Module for Desktop Applications 15:
    zypper in -t patch SUSE-SLE-Module-Desktop-Applications-15-2019-720=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (aarch64 ppc64le s390x x86_64):
    • libgxps-debuginfo-0.3.0-4.3.29
    • libgxps-debugsource-0.3.0-4.3.29
    • libgxps-tools-0.3.0-4.3.29
    • libgxps-tools-debuginfo-0.3.0-4.3.29
  • SUSE Linux Enterprise Module for Desktop Applications 15 (aarch64 ppc64le s390x x86_64):
    • libgxps-debuginfo-0.3.0-4.3.29
    • libgxps-debugsource-0.3.0-4.3.29
    • libgxps-devel-0.3.0-4.3.29
    • libgxps2-0.3.0-4.3.29
    • libgxps2-debuginfo-0.3.0-4.3.29
    • typelib-1_0-GXPS-0_1-0.3.0-4.3.29

References: