Security update for openssl-1_0_0

SUSE Security Update: Security update for openssl-1_0_0
Announcement ID: SUSE-SU-2019:0572-1
Rating: moderate
References: #1117951 #1127080
Cross-References: CVE-2019-1559
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP4
  • SUSE Linux Enterprise Server 12-SP4
  • SUSE Linux Enterprise Desktop 12-SP4

An update that solves one vulnerability and has one errata is now available.

Description:

This update for openssl-1_0_0 fixes the following issues:
Security issues fixed:

  • The 9 Lives of Bleichenbacher's CAT: Cache Attacks on TLS Implementations (bsc#1117951)
  • CVE-2019-1559: Fixed OpenSSL 0-byte Record Padding Oracle which under certain circumstances a TLS server can be forced to respond differently to a client and lead to the decryption of the data (bsc#1127080).

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP4:
    zypper in -t patch SUSE-SLE-SDK-12-SP4-2019-572=1
  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-572=1
  • SUSE Linux Enterprise Desktop 12-SP4:
    zypper in -t patch SUSE-SLE-DESKTOP-12-SP4-2019-572=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.6.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.6.1
    • openssl-1_0_0-debugsource-1.0.2p-3.6.1
  • SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.6.1
    • libopenssl1_0_0-1.0.2p-3.6.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.6.1
    • libopenssl1_0_0-hmac-1.0.2p-3.6.1
    • openssl-1_0_0-1.0.2p-3.6.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.6.1
    • openssl-1_0_0-debugsource-1.0.2p-3.6.1
  • SUSE Linux Enterprise Server 12-SP4 (s390x x86_64):
    • libopenssl1_0_0-32bit-1.0.2p-3.6.1
    • libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.6.1
    • libopenssl1_0_0-hmac-32bit-1.0.2p-3.6.1
  • SUSE Linux Enterprise Server 12-SP4 (noarch):
    • openssl-1_0_0-doc-1.0.2p-3.6.1
  • SUSE Linux Enterprise Desktop 12-SP4 (x86_64):
    • libopenssl-1_0_0-devel-1.0.2p-3.6.1
    • libopenssl1_0_0-1.0.2p-3.6.1
    • libopenssl1_0_0-32bit-1.0.2p-3.6.1
    • libopenssl1_0_0-debuginfo-1.0.2p-3.6.1
    • libopenssl1_0_0-debuginfo-32bit-1.0.2p-3.6.1
    • openssl-1_0_0-1.0.2p-3.6.1
    • openssl-1_0_0-debuginfo-1.0.2p-3.6.1
    • openssl-1_0_0-debugsource-1.0.2p-3.6.1

References: