Recommended update for python-Werkzeug

SUSE Recommended Update: Recommended update for python-Werkzeug
Announcement ID: SUSE-RU-2019:3367-1
Rating: moderate
References: #1143320
Affected Products:
  • SUSE Linux Enterprise Module for Public Cloud 12

An update that has one recommended fix can now be installed.

Description:

This update for python-Werkzeug contains the following fixes:

  • Fix testsuite failures on SLE-12. (bsc#1143320) - Add python to BuildRequires - Add python-requests to BuildRequires - Set LANG=en_US.UTF-8 when running testsuite - Set PYTHONDONTWRITEBYTECODE=1 when running testsuite - Use %pytest macro to invoke testsuite
  • Run fdupes to hardlink duplicate files + Add fdupes to BuildRequires + Add %fdupes invocation to %install

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Public Cloud 12:
    zypper in -t patch SUSE-SLE-Module-Public-Cloud-12-2019-3367=1

Package List:

  • SUSE Linux Enterprise Module for Public Cloud 12 (noarch):
    • python-Werkzeug-0.12.2-10.7.1
    • python3-Werkzeug-0.12.2-10.7.1

References: