Recommended update for libtcnative-1-0

SUSE Recommended Update: Recommended update for libtcnative-1-0
Announcement ID: SUSE-RU-2019:3328-1
Rating: moderate
References: #1130843 #202339 #622430
Affected Products:
  • SUSE Linux Enterprise Module for Web Scripting 15

An update that has three recommended fixes can now be installed.

Description:

This update for libtcnative-1-0 fixes the following issues:

  • Fix incompatibility with Tomcat. (bsc#1130843)
  • Include 'libtcnative-1.so' in the main package. (bsc#622430)
  • Enable 'jsvc' and 'apr/epoll' in Tomcat packages. (bsc#202339)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Web Scripting 15:
    zypper in -t patch SUSE-SLE-Module-Web-Scripting-15-2019-3328=1

Package List:

  • SUSE Linux Enterprise Module for Web Scripting 15 (aarch64 ppc64le s390x x86_64):
    • libtcnative-1-0-1.2.23-1.3.1
    • libtcnative-1-0-devel-1.2.23-1.3.1

References: