Recommended update for xen

SUSE Recommended Update: Recommended update for xen
Announcement ID: SUSE-RU-2019:3199-1
Rating: moderate
References: #1027519 #1157047 #1157888
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 12-SP5
  • SUSE Linux Enterprise Server 12-SP5

An update that has three recommended fixes can now be installed.

Description:

This update for xen fixes the following issues:

  • Fixed a privilege escaltion where an untrusted domain with access to a physical device can DMA into host memory (bsc#1157888 XSA-306).
  • Fixed an issue where PCI passthrough failed on AMD machine xen host (bsc#1157047).

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Software Development Kit 12-SP5:
    zypper in -t patch SUSE-SLE-SDK-12-SP5-2019-3199=1
  • SUSE Linux Enterprise Server 12-SP5:
    zypper in -t patch SUSE-SLE-SERVER-12-SP5-2019-3199=1

Package List:

  • SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 x86_64):
    • xen-debugsource-4.12.1_08-3.5.4
    • xen-devel-4.12.1_08-3.5.4
  • SUSE Linux Enterprise Server 12-SP5 (x86_64):
    • xen-4.12.1_08-3.5.4
    • xen-debugsource-4.12.1_08-3.5.4
    • xen-doc-html-4.12.1_08-3.5.4
    • xen-libs-32bit-4.12.1_08-3.5.4
    • xen-libs-4.12.1_08-3.5.4
    • xen-libs-debuginfo-32bit-4.12.1_08-3.5.4
    • xen-libs-debuginfo-4.12.1_08-3.5.4
    • xen-tools-4.12.1_08-3.5.4
    • xen-tools-debuginfo-4.12.1_08-3.5.4
    • xen-tools-domU-4.12.1_08-3.5.4
    • xen-tools-domU-debuginfo-4.12.1_08-3.5.4

References: