Prometheus and Grafana, 389-ds fixes and other skuba fixes

SUSE Recommended Update: Prometheus and Grafana, 389-ds fixes and other skuba fixes
Announcement ID: SUSE-RU-2019:3129-1
Rating: moderate
References: #1140533 #1151340 #1151343 #1151414 #1151689 #1155173 #1156667 #1157332
Affected Products:
  • SUSE CaaS Platform 4.0

An update that has 8 recommended fixes can now be installed.

Description:

= Required Actions
== Prometheus and Grafana installation instructions
You will need to use `helm` and `kubectl` to deploy Prometheus and Grafana. Refer to "Monitoring chapter" in the admin guide: https://documentation.suse.com/suse-caasp/4.0/html/caasp-admin/_monitoring. html#_monitoring_stack
== 389-ds update instructions
`389-ds` containers have been updated in `registry.suse.com`. In order to deploy your `389-ds` container, see "Configuring and external ldap server" at the admin guide: https://susedoc.github.io/doc-caasp/master/caasp-admin/single-html/#_config uring_an_external_ldap_server
== skuba update instructions
Update skuba on your management workstation as you would do with any other package.
Refer to "15 SP1 Admin Guide: Updating Software with Zypper": https://documentation.suse.com/sles/15-SP1/single-html/SLES-admin/#sec-zypp er-softup

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE CaaS Platform 4.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE CaaS Platform 4.0 (noarch):
    • release-notes-caasp-4.0.20191127-4.9.1
    • skuba-update-1.1.2-3.6.1
  • SUSE CaaS Platform 4.0 (x86_64):
    • caasp-release-4.0.3-17.1
    • patterns-caasp-Management-1.1-4.3.1
    • patterns-caasp-Node-1.15-1.2-3.3.1
    • skuba-1.1.2-3.6.1

References: