Recommended update for pacemaker

SUSE Recommended Update: Recommended update for pacemaker
Announcement ID: SUSE-RU-2019:3098-1
Rating: moderate
References: #1151007
Affected Products:
  • SUSE Linux Enterprise High Availability 15-SP1

An update that has one recommended fix can now be installed.

Description:

This update for pacemaker fixes the following issues:

  • Fixes and improvements for fencer. (bsc#1151007) - Indicate fencing target in the logs when scheduling and executing fencing command and improved log messages. - Make sure concurrent fencing commands get triggered to execute. - Other commands and actions cannot be blocked by pending on the fencing. - No need to check the length of a non-empty list for pending fencing actions.

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15-SP1:
    zypper in -t patch SUSE-SLE-Product-HA-15-SP1-2019-3098=1

Package List:

  • SUSE Linux Enterprise High Availability 15-SP1 (aarch64 ppc64le s390x x86_64):
    • libpacemaker-devel-2.0.1+20190417.13d370ca9-3.6.1
    • libpacemaker3-2.0.1+20190417.13d370ca9-3.6.1
    • libpacemaker3-debuginfo-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-cli-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-cli-debuginfo-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-debuginfo-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-debugsource-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-remote-2.0.1+20190417.13d370ca9-3.6.1
    • pacemaker-remote-debuginfo-2.0.1+20190417.13d370ca9-3.6.1
  • SUSE Linux Enterprise High Availability 15-SP1 (noarch):
    • pacemaker-cts-2.0.1+20190417.13d370ca9-3.6.1

References: