Recommended update for python-kubernetes

SUSE Recommended Update: Recommended update for python-kubernetes
Announcement ID: SUSE-RU-2019:2929-1
Rating: moderate
References: #1151481
Affected Products:
  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Enterprise Storage 6

An update that has one recommended fix can now be installed.

Description:

This update for python-kubernetes fixes the following issues:

  • python-ipaddress is only required for building on Python2 (on Python3 is part of the standard library)
  • Backport fix for base64 padding in kubeconfig (bsc#1151481)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0:
    zypper in -t patch SUSE-SLE-Module-SUSE-Manager-Server-4.0-2019-2929=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2929=1
  • SUSE Enterprise Storage 6:
    zypper in -t patch SUSE-Storage-6-2019-2929=1

Package List:

  • SUSE Linux Enterprise Module for SUSE Manager Server 4.0 (noarch):
    • python3-kubernetes-8.0.1-3.3.2
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (noarch):
    • python2-kubernetes-8.0.1-3.3.2
    • python3-kubernetes-8.0.1-3.3.2
  • SUSE Enterprise Storage 6 (noarch):
    • python3-kubernetes-8.0.1-3.3.2

References: