Recommended update for gnu-compilers-hpc

SUSE Recommended Update: Recommended update for gnu-compilers-hpc
Announcement ID: SUSE-RU-2019:2679-1
Rating: moderate
References: #1116458
Affected Products:
  • SUSE Linux Enterprise Module for HPC 15

An update that has one recommended fix can now be installed.

Description:

This update for gnu-compilers-hpc fixes the following issues:

  • Add support for gcc v.8 and v.9 for SLE-15 & SLE-15-SP1. (jsc#SLE-7766)
  • Add links from the generic compiler binary names cc, cpp, c++ and fc to the compiler specific names in the package private binary directory.
  • Define _hpc_gnu_module (bsc#1116458).

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for HPC 15:
    zypper in -t patch SUSE-SLE-Module-HPC-15-2019-2679=1

Package List:

  • SUSE Linux Enterprise Module for HPC 15 (noarch):
    • gnu-compilers-hpc-1.4-5.3.1
    • gnu-compilers-hpc-devel-1.4-5.3.1
    • gnu-compilers-hpc-macros-devel-1.4-5.3.1
    • gnu8-compilers-hpc-1.4-5.3.1
    • gnu8-compilers-hpc-devel-1.4-5.3.1
    • gnu8-compilers-hpc-macros-devel-1.4-5.3.1

References: