Recommended update for python-kiwi

SUSE Recommended Update: Recommended update for python-kiwi
Announcement ID: SUSE-RU-2019:2642-1
Rating: important
References: #1112357 #1124885 #1127173 #1129566 #1132455 #1136444 #1142899 #1143033 #1149686
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1

An update that has 9 recommended fixes can now be installed.

Description:

This update for python-kiwi fixes the following issues:

  • Added --add-bootstrap-packages option (bsc#1149686)
  • Avoids now the default installation of dracut kiwi modules (bsc#1142899, bsc#1136444)
  • Add support for custom fstab script extension (bsc#1129566)
  • Fixes an issue where python-kiwi crashed when the HOME directory is missing (bsc#1149686)
  • New spare partition types have been added: (bsc#1129566) * spare_part_fs="fsname" * spare_part_mountpoint="/location" * spare_part_is_last="true|false"
  • Preserve licenses/other txt files by baseStripFirmware (bsc#1132455
  • Added support for fstab.patch file (bsc#1129566)
  • Makes the bundler shasum file compatible with 'sha256sum --check' command (bsc#1127173)
  • Fixes an issue when importing signing keys (bsc#1112357)
  • Fixes an issue where grub2 didn't display UTF-8 characters properly (bsc#1124885)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2642=1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP1-2019-2642=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • python-kiwi-debugsource-9.18.16-3.6.1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • dracut-kiwi-lib-9.18.16-3.6.1
    • dracut-kiwi-live-9.18.16-3.6.1
    • dracut-kiwi-oem-dump-9.18.16-3.6.1
    • dracut-kiwi-oem-repart-9.18.16-3.6.1
    • dracut-kiwi-overlay-9.18.16-3.6.1
    • kiwi-man-pages-9.18.16-3.6.1
    • kiwi-tools-9.18.16-3.6.1
    • kiwi-tools-debuginfo-9.18.16-3.6.1
    • python-kiwi-debugsource-9.18.16-3.6.1
    • python3-kiwi-9.18.16-3.6.1
  • SUSE Linux Enterprise Module for Development Tools 15-SP1 (x86_64):
    • kiwi-pxeboot-9.18.16-3.6.1

References: