Recommended update for openssl-ibmca

SUSE Recommended Update: Recommended update for openssl-ibmca
Announcement ID: SUSE-RU-2019:2509-1
Rating: moderate
References: #1142855
Affected Products:
  • SUSE Linux Enterprise Server 12-SP4

An update that has one recommended fix can now be installed.

Description:

This update for openssl-ibmca fixes the following issues:

  • The code in e_ibmca.c does a dlopen for libica.so, instead of linking against the shared library. As a result, if the package containing libica.so isn't installed, problems occur. Added a "Requires: libica-tools" to the spec file to fix this. (bsc#1142855)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 12-SP4:
    zypper in -t patch SUSE-SLE-SERVER-12-SP4-2019-2509=1

Package List:

  • SUSE Linux Enterprise Server 12-SP4 (s390x):
    • openssl-ibmca-2.0.0-3.6.1
    • openssl-ibmca-32bit-2.0.0-3.6.1
    • openssl-ibmca-debuginfo-2.0.0-3.6.1
    • openssl-ibmca-debuginfo-32bit-2.0.0-3.6.1
    • openssl-ibmca-debugsource-2.0.0-3.6.1

References: