Recommended update for openssl-ibmca

SUSE Recommended Update: Recommended update for openssl-ibmca
Announcement ID: SUSE-RU-2019:2500-1
Rating: moderate
References: #1142286 #1151281
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP1

An update that has two recommended fixes can now be installed.

Description:

This update for openssl-ibmca fixes the following issues:
openssl-ibmca was upgraded to version 2.0.3 (jsc#SLE-6123, jsc#SLE-6424):

  • Add MSA9 CPACF support for ECDSA sign/verify

Additional fixes:
  • The code in e_ibmca.c does a dlopen for libica.so.3, instead of linking against the shared library. As a result, if the package containing libica.so.3 isn't installed, problems occur. Added a "Requires: libica3" to the spec file to fix this. (bsc#1142286)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2019-2500=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (s390x):
    • openssl-ibmca-2.0.3-7.8.1
    • openssl-ibmca-debuginfo-2.0.3-7.8.1
    • openssl-ibmca-debugsource-2.0.3-7.8.1

References: