Recommended update for crmsh

SUSE Recommended Update: Recommended update for crmsh
Announcement ID: SUSE-RU-2019:2433-1
Rating: moderate
References: #1093564 #1116559 #1120554 #1120555 #1120587 #1123187 #1129380 #1129383 #1129719 #1130715 #1135696
Affected Products:
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • SUSE Linux Enterprise High Availability 15

An update that has 11 recommended fixes can now be installed.

Description:

This update for crmsh contains the following fixes:
Specific hb_report issues fixed: - Collect output of "sbd dump" and "sbd list". (bsc#1129383) - Using Tempfile class to manage tempfiles. - Handle UnicodeDecodeError on special position. (bsc#1130715) - Analysis.txt includes warning, error, critical messages. (bsc#1135696) Update from 4.0.0+git.1542103310.dd114188 to version 4.0.0+git.1553262403.5da14dfa5 includes: * Add timestamp for DEBUG messages. (bsc#1129380) * Check if command and related files exists. (bsc#1129719) * Add "promotable", "promoted-max" and "promoted-node-max" constants in clone meta attributes. * Fix #425 The ID attribute is not required for select and select_attributes. * Set kind for order constraints, not score. (bsc#1123187) * low: utils: add support for dpkg. * low: utils: add support for apt-get. * low: utils: convert string contstants to bytes. * Warning messages start with like "WARNING:" instead of "!". (bsc#1120587, bsc#1120586) * crmsh crashed when using configure->template->apply. (bsc#1120554, bsc#1120555) * Increase log level for verification. (bsc#1116559) * Fix UnicodeEncodeError while print. (bsc#1093564)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-2019-2433=1
  • SUSE Linux Enterprise High Availability 15:
    zypper in -t patch SUSE-SLE-Product-HA-15-2019-2433=1

Package List:

  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 (noarch):
    • crmsh-test-4.0.0+git.1553262403.5da14df5-3.11.1
  • SUSE Linux Enterprise High Availability 15 (noarch):
    • crmsh-4.0.0+git.1553262403.5da14df5-3.11.1
    • crmsh-scripts-4.0.0+git.1553262403.5da14df5-3.11.1

References: