Recommended update for krb5

SUSE Recommended Update: Recommended update for krb5
Announcement ID: SUSE-RU-2019:2361-1
Rating: moderate
References: #1081947 #1144047
Affected Products:
  • SUSE Linux Enterprise Module for Server Applications 15-SP1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1

An update that has two recommended fixes can now be installed.

Description:

This update for krb5 contains the following fixes:

  • Integrate pam_keyinit PAM module, ksu-pam.d. (bsc#1081947)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP1-2019-2361=1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2361=1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1:
    zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2019-2361=1

Package List:

  • SUSE Linux Enterprise Module for Server Applications 15-SP1 (aarch64 ppc64le s390x x86_64):
    • krb5-debuginfo-1.16.3-3.6.1
    • krb5-debugsource-1.16.3-3.6.1
    • krb5-plugin-kdb-ldap-1.16.3-3.6.1
    • krb5-plugin-kdb-ldap-debuginfo-1.16.3-3.6.1
    • krb5-server-1.16.3-3.6.1
    • krb5-server-debuginfo-1.16.3-3.6.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (aarch64 ppc64le s390x x86_64):
    • krb5-mini-1.16.3-3.6.1
    • krb5-mini-debuginfo-1.16.3-3.6.1
    • krb5-mini-debugsource-1.16.3-3.6.1
    • krb5-mini-devel-1.16.3-3.6.1
  • SUSE Linux Enterprise Module for Open Buildservice Development Tools 15-SP1 (x86_64):
    • krb5-32bit-debuginfo-1.16.3-3.6.1
    • krb5-debugsource-1.16.3-3.6.1
    • krb5-devel-32bit-1.16.3-3.6.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x x86_64):
    • krb5-1.16.3-3.6.1
    • krb5-client-1.16.3-3.6.1
    • krb5-client-debuginfo-1.16.3-3.6.1
    • krb5-debuginfo-1.16.3-3.6.1
    • krb5-debugsource-1.16.3-3.6.1
    • krb5-devel-1.16.3-3.6.1
    • krb5-plugin-preauth-otp-1.16.3-3.6.1
    • krb5-plugin-preauth-otp-debuginfo-1.16.3-3.6.1
    • krb5-plugin-preauth-pkinit-1.16.3-3.6.1
    • krb5-plugin-preauth-pkinit-debuginfo-1.16.3-3.6.1
  • SUSE Linux Enterprise Module for Basesystem 15-SP1 (x86_64):
    • krb5-32bit-1.16.3-3.6.1
    • krb5-32bit-debuginfo-1.16.3-3.6.1

References: