Recommended update for e2fsprogs

SUSE Recommended Update: Recommended update for e2fsprogs
Announcement ID: SUSE-RU-2019:1761-1
Rating: moderate
References: #1128383 #1135261
Affected Products:
  • SUSE CaaS Platform 3.0

An update that has two recommended fixes can now be installed.

Description:

This update for e2fsprogs fixes the following issues:

  • Revert "mke2fs: prevent creation of unmountable ext4 with large flex_bg count". (bsc#1135261)

  • Place metadata blocks in the last flex_bg so they are contiguous. (bsc#1135261)

  • Check and fix tails of all bitmaps. (bsc#1128383)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE CaaS Platform 3.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE CaaS Platform 3.0 (x86_64):
    • e2fsprogs-1.42.11-16.3.1
    • e2fsprogs-debuginfo-1.42.11-16.3.1
    • e2fsprogs-debugsource-1.42.11-16.3.1
    • libcom_err2-1.42.11-16.3.1
    • libcom_err2-debuginfo-1.42.11-16.3.1
    • libext2fs2-1.42.11-16.3.1
    • libext2fs2-debuginfo-1.42.11-16.3.1

References: