Recommended update for kubernetes-salt

SUSE Recommended Update: Recommended update for kubernetes-salt
Announcement ID: SUSE-RU-2019:1711-1
Rating: moderate
References: #1122439 #1130538 #1130661
Affected Products:
  • SUSE CaaS Platform 3.0

An update that has three recommended fixes can now be installed.

Description:


This update fixes the following issues:

  • The PodSecurityPolicy for tiller did not have the correct permissions
  • The firewall settings of the container network were too restrictive and could cause containers in a subnetwork to be terminated or fail
  • Wrong parsing of an empty configuration string could cause services to fail to start

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE CaaS Platform 3.0:
    To install this update, use the SUSE CaaS Platform Velum dashboard. It will inform you if it detects new updates and let you then trigger updating of the complete cluster in a controlled way.

Package List:

  • SUSE CaaS Platform 3.0 (noarch):
    • kubernetes-salt-3.0.0+git_r986_d801419-3.71.1

References: