Recommended update for resource-agents

SUSE Recommended Update: Recommended update for resource-agents
Announcement ID: SUSE-RU-2019:1555-1
Rating: moderate
References: #1114855 #1133337 #1133962 #1137038 #1137130 #1137231
Affected Products:
  • SUSE Linux Enterprise High Availability 15-SP1

An update that has 6 recommended fixes can now be installed.

Description:

This update for resource-agents fixes the following issues:

  • aws-vpc-move-ip: Fix for VM having multiple network interfaces (bsc#1133962)
  • add network namespace support to IPaddr2
  • [rabbitmq] Stop redirecting all output to /dev/null in set_policy
  • LVM-activate: only check locking_type when LVM is lower than v2.03
  • redis: Filter warning from stderr when calling 'redis-cli -a'
  • Fixes version string with vendor trailer comparison (bsc#1133337)
  • azure-events: change message log level for the non action messages (bsc#1137038, bsc#1137231)
  • Fixes CTDB resource agent for Samba 4.9.0 and later (bsc#1137130)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise High Availability 15-SP1:
    zypper in -t patch SUSE-SLE-Product-HA-15-SP1-2019-1555=1

Package List:

  • SUSE Linux Enterprise High Availability 15-SP1 (aarch64 ppc64le s390x x86_64):
    • ldirectord-4.2.0+git157.40de8382-4.7.1
    • resource-agents-4.2.0+git157.40de8382-4.7.1
    • resource-agents-debuginfo-4.2.0+git157.40de8382-4.7.1
    • resource-agents-debugsource-4.2.0+git157.40de8382-4.7.1
  • SUSE Linux Enterprise High Availability 15-SP1 (noarch):
    • monitoring-plugins-metadata-4.2.0+git157.40de8382-4.7.1

References: