Recommended update for tcsh

SUSE Recommended Update: Recommended update for tcsh
Announcement ID: SUSE-RU-2019:14189-1
Rating: moderate
References: #1134508 #992577
Affected Products:
  • SUSE Linux Enterprise Server 11-SP4-LTSS
  • SUSE Linux Enterprise Point of Sale 11-SP3
  • SUSE Linux Enterprise Debuginfo 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP3

An update that has two recommended fixes can now be installed.

Description:

This update for tcsh provides the following fix:

  • Make a copy of the file descriptor of the history file to be able not only to lock but also unlock the file. (bsc#992577, bsc#1134508)

Patch Instructions:

To install this SUSE Recommended Update use the SUSE recommended installation methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

  • SUSE Linux Enterprise Server 11-SP4-LTSS:
    zypper in -t patch slessp4-tcsh-14189=1
  • SUSE Linux Enterprise Point of Sale 11-SP3:
    zypper in -t patch sleposp3-tcsh-14189=1
  • SUSE Linux Enterprise Debuginfo 11-SP4:
    zypper in -t patch dbgsp4-tcsh-14189=1
  • SUSE Linux Enterprise Debuginfo 11-SP3:
    zypper in -t patch dbgsp3-tcsh-14189=1

Package List:

  • SUSE Linux Enterprise Server 11-SP4-LTSS (i586 ppc64 s390x x86_64):
    • tcsh-6.18.01-9.7.1
  • SUSE Linux Enterprise Point of Sale 11-SP3 (i586):
    • tcsh-6.18.01-9.7.1
  • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 ppc64 s390x x86_64):
    • tcsh-debuginfo-6.18.01-9.7.1
    • tcsh-debugsource-6.18.01-9.7.1
  • SUSE Linux Enterprise Debuginfo 11-SP3 (i586 s390x x86_64):
    • tcsh-debuginfo-6.18.01-9.7.1
    • tcsh-debugsource-6.18.01-9.7.1

References: